注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

山歌

微信公众号:Jack-Xiaoshan

 
 
 
 
 

日志

 
 

imagemagick linux安装  

2009-10-21 02:39:02|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
[root@yichild im]# rpmbuild --rebuild  ImageMagick-6.2.8.0-3.el5.4.src.rpm Installing ImageMagick-6.2.8.0-3.el5.4.src.rpm warning: InstallSourcePackage: Header V3 DSA signature: NOKEY, key ID 37017186 warning: user brewbuilder does not exist - using root 。。。。。 error: Failed build dependencies: freetype-devel is needed by ImageMagick-6.2.8.0-3.4.i386 libpng-devel is needed by ImageMagick-6.2.8.0-3.4.i386 freetype-devel >= 2.0.1 is needed by ImageMagick-6.2.8.0-3.4.i386 ghostscript-devel is needed by ImageMagick-6.2.8.0-3.4.i386 libwmf-devel is needed by ImageMagick-6.2.8.0-3.4.i386 libX11-devel is needed by ImageMagick-6.2.8.0-3.4.i386 libXext-devel is needed by ImageMagick-6.2.8.0-3.4.i386 libXt-devel is needed by ImageMagick-6.2.8.0-3.4.i386 lcms-devel is needed by ImageMagick-6.2.8.0-3.4.i386 librsvg2-devel is needed by ImageMagick-6.2.8.0-3.4.i386 出现以上错误,到redhat安装盘找到相应的rpm,用rpm -ivh 安装。 出现:V3 DSA signature: NOKEY, key ID错误时用 rpm -ivh --force --nodeps 安装rpm包。 实在没办法安装成功时,安装bin版本 ftp://ftp.imagemagick.org/pub/ImageMagick/binaries/ i386 32位的安装:ImageMagick-i686-pc-linux-gnu.tar.gz 然后设置相关的环境变量:
setenv MAGICK_HOME /net/doctools/tools/master/graphics setenv LD_LIBRARY_PATH "${MAGICK_HOME}/lib"
  评论这张
 
阅读(19)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017